GetDefaultNameForKeySchedule Method


View Schedule Get Default Name For Key Schedule Method

Gets the default view name that will be used when creating a key schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static string GetDefaultNameForKeySchedule(
	Document document,
	ElementId categoryId
)

Parameters

document Document
The document to which the new schedule will be added.
categoryId ElementId
The ID of the category of elements that the schedule's keys will be associated with.

Return Value

String
The default view name.
Exceptions
Exception Condition
ArgumentException document is not a project document. -or- categoryId is not a valid category for a key schedule.
ArgumentNullException A non-optional argument was null
See Also