AreaBasedLoadBoundaryLineData Class


Area Based Load Boundary Line Data Class

Wrapper class used to access area based load boundary line related data.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Electrical AreaBasedLoadBoundaryLineData

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class AreaBasedLoadBoundaryLineData : IDisposable

The AreaBasedLoadBoundaryLineData type exposes the following members.

Properties
Name Description
Public property BottomLevelId The bottom level id of the area based load boundary line.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property TopLevelId The top level id of the area based load boundary line.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the AreaBasedLoadBoundaryLineData
Public method GetLevelIdsInRange Returns level ids between the top level and the bottom level (including the top level and the bottom level) of the area based load boundary line.
Public method IsElevationWithinRange Checks whether the given elevation is between the bottom level and the top level(including the bottom level and the top level) of the area based load boundary line.
Public method IsLevelWithinRange Checks whether the given level is between the bottom level and the top level (including the bottom level and the top level) of the area based load boundary line.
Top
See Also