SubMenuItem Constructor


Sub Menu Item Constructor

Initialize the item data.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public SubMenuItem(
	string name,
	ContextMenu subMenu
)

Parameters

name String
The name will show on menu.
subMenu ContextMenu
The object of child ContextMenu.
Exceptions
Exception Condition
ArgumentException name is an empty string or contains only whitespace.
ArgumentNullException A non-optional argument was null
See Also