SetDeckProfileId Method


Compound Structure Set Deck Profile Id Method

Sets the profile loop to use for the specified structural deck.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetDeckProfileId(
	int layerIdx,
	ElementId profileId
)

Parameters

layerIdx Int32
Index of a layer in the CompoundStructure.
profileId ElementId
The element id of a FamilySymbol which contains a profile loop to be used by the specified layer if it is a structural deck.
Exceptions
Exception Condition
ArgumentException The layer is not a structural deck.
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException The layer index is out of range.
See Also