Fabric |
Returns the profile (not including generated fillets) that defines the shape of the Fabric Sheet bending.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Return Value
CurveLoopThe profile that defines the shape of the fabric sheet bending for bent fabric sheet, for flat fabric sheet will be returned.

The returned profile defines the center-curve of a wire. Note that bent Fabric Sheets can have planar geometry, but flat Fabric Sheets are always planar.

#region Autodesk.Revit.DB.Structure.FabricSheet.SetBendProfile(Autodesk.Revit.DB.CurveLoop)
private void ModifyBentFabricSheet(Document document, FabricSheet bentFabricSheet)
{
CurveLoop newBendingProfile = CurveLoop.CreateViaOffset(bentFabricSheet.GetBendProfile(), 0.5, new XYZ(0, 0, -1));
bentFabricSheet.SetBendProfile(newBendingProfile);
// Give the user some information
TaskDialog.Show("Revit", string.Format("Bent Fabric Sheet ID='{0}' modified successfully.", bentFabricSheet.Id.ToString()));
}
#endregion