Point |
This class encapsulates a point light shape.

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The PointLightShape type exposes the following members.

Name | Description | |
---|---|---|
![]() | PointLightShape | Creates a point light shape object. |
![]() | PointLightShape(PointLightShape) | Creates a copy of the given point light shape |

Name | Description | |
---|---|---|
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from LightShape ) |

Name | Description | |
---|---|---|
![]() | Clone | Creates a copy of the LightShape derived object. (Inherited from LightShape ) |
![]() | Dispose | (Inherited from LightShape ) |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |