RebarShapeDefinitionByArcType Enumeration


Rebar Shape Definition By Arc Type Enumeration

A RebarShapeDefinitionByArc takes one of three forms.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public enum RebarShapeDefinitionByArcType
Members
Member name Value Description
Arc 0 An arc, subtending an angle less than 360 degrees.
LappedCircle 1 A full circle, subtending an angle more than 360 degrees and less than 720 degrees. The behavior in Revit is the same as Arc, but an extra complete circle is included in the rebar.
Spiral 2 A helical bar. The extent of the helix is determined by the Rebar properties Height and Pitch.
See Also