InitialIntensity Class


Initial Intensity Class

This class is the base class for calculating lighting initial intensity.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class InitialIntensity : IDisposable

The InitialIntensity type exposes the following members.

Properties
Name Description
Public property InitialIntensityValue The calculated initial intensity value.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method Clone Creates a copy of the InitialIntensity derived object.
Public method Dispose Releases all resources used by the InitialIntensity
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also