RebarSpliceOptions Constructor


Rebar Splice Options Constructor

Constructs a RebarSpliceOptions

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public RebarSpliceOptions(
	Document document,
	ElementId spliceTypeId,
	RebarSplicePosition splicePosition
)

Parameters

document Document
The document.
spliceTypeId ElementId
The splice type id.
splicePosition RebarSplicePosition
The splice line position.
Exceptions
Exception Condition
ArgumentException The provided spliceTypeId is not a Rebar Splice Type id. It should be an ElementType of BuiltInCategory.OST_RebarSpliceType category.
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
See Also