TemperatureRatingTypeSet Class


Temperature Rating Type Set Class

A set that contains TemperatureRating types.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB APIObject
Autodesk.Revit.DB.Electrical TemperatureRatingTypeSet

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class TemperatureRatingTypeSet : APIObject, 
	IEnumerable

The TemperatureRatingTypeSet type exposes the following members.

Constructors
Name Description
Public method TemperatureRatingTypeSet Initializes a new instance of the TemperatureRatingTypeSet class
Top
Properties
Name Description
Public property IsEmpty Test to see if the set is empty.
Public property Size Returns the number of TemperatureRating types that are in the set.
Top
Methods
Name Description
Public method Clear Removes every TemperatureRating type from the set, rendering it empty.
Public method Contains Tests for the existence of a TemperatureRating type within the set.
Public method Erase Removes a specified TemperatureRating type from the set.
Public method ForwardIterator Retrieve a forward moving iterator to the set.
Public method GetEnumerator Retrieve a forward moving iterator to the set.
Public method Insert Insert the specified TemperatureRating type into the set.
Public method ReverseIterator Retrieve a backward moving iterator to the set.
Top
See Also