AnalysisDisplayDiagramSettings Class


Analysis Display Diagram Settings Class

Contains diagram settings for analysis display style element.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Analysis AnalysisDisplayDiagramSettings

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class AnalysisDisplayDiagramSettings : IDisposable

The AnalysisDisplayDiagramSettings type exposes the following members.

Constructors
Name Description
Public method AnalysisDisplayDiagramSettings Constructs a default instance of diagram settings.
Public method AnalysisDisplayDiagramSettings(AnalysisDisplayDiagramSettings) Constructs a new copy of the input AnalysisDisplayDiagramSettings object.
Top
Properties
Name Description
Public property FenceType Type of diagram fence visualization.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property OutlineColor Color of outline and fence lines in the diagram.
Public property OutlineLineWeight Line weight of outline and fence lines in the diagram.
Public property Rounding Increment to which numeric values of analysis results are rounded in diagram.
Public property TextLabelType Type of diagram text label visualization.
Public property TextTypeId Element id of text associated with the settings.
Public property Transparency Transparency percentage of diagram color fill
Top
Methods
Name Description
Public method Dispose Releases all resources used by the AnalysisDisplayDiagramSettings
Public method IsEqual Compares two diagram settings objects.
Top
See Also