PlaceGroup Method


Item Factory Base Place Group Method

Place an instance of a Model Group into the Autodesk Revit document, using a location and a group type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public Group PlaceGroup(
	XYZ location,
	GroupType groupType
)

Parameters

location XYZ
The physical location where the group is to be placed.
groupType GroupType
A GroupType object that represents the type of group that is to be placed.

Return Value

Group
If creation was successful then an instance to the new group is returned, otherwise .
Remarks
This method is used to place a new instance of an existing group type within the document. The group's origin will placed at the point specified by the location. All group types within the document can be found by iterating over the document and looking for elements of type GroupType .
See Also