DataExchangeMessageSeverity Enumeration


Data Exchange Message Severity Enumeration

Error levels for DataExchangeLog

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public enum DataExchangeMessageSeverity
Members
Member name Value Description
Info 0 Informational message, such as successful creation fo a face, edge or a solid.
Warning 1 A potential problem. The converted data should be carefully examined and/or compared to the source data
Error 2 A problem. The converted data should be carefully examined and/or compared to the source data. The application may want to cancel the conversion process.
FatalError 3 A serious problem that makes further data conversion pointless. The conversion process will be cancelled.
See Also