FamilySizeTableErrorInfo Class


Family Size Table Error Info Class

Error information generated from the CSV file import of a FamilySizeTable.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB FamilySizeTableErrorInfo

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class FamilySizeTableErrorInfo : IDisposable

The FamilySizeTableErrorInfo type exposes the following members.

Constructors
Name Description
Public method FamilySizeTableErrorInfo Constructs a new FamilySizeTableErrorInfo with default settings.
Top
Properties
Name Description
Public property FamilySizeTableErrorType The error type.
Public property FilePath The path of the imported CSV file.
Public property InvalidColumnIndex The index of the invalid column.
Public property InvalidHeaderText The invalid header text.
Public property InvalidRowIndex The index of the invalid row.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the FamilySizeTableErrorInfo
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also