Viewport Class


Viewport Class

An element that establishes the placement of a view on a sheet.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class Viewport : Element

The Viewport type exposes the following members.

Properties
Name Description
Public property LabelLineLength The length of the viewport label line in sheet space, measured in feet.
Public property LabelOffset The offset is a two-dimensional vector from left bottom corner of the viewport with Rotation set to None to the left end of the viewport label line. The Z coordinate is ignored.
Public property Rotation The rotation of the viewport on the sheet.
Public property SheetId The element id of the ViewSheet on which the viewport appears, or InvalidElementId if this viewport does not associate a view with placement onto a sheet.
Public property ViewId The element id of the associated View.
Public property ViewportPositioning Specifies the method the viewport will be positioned on the sheet when swapped to another view. Default is set to ViewportPositioning::ViewportCenter.
Top
Methods
Name Description
Public method Static member CanAddViewToSheet Verifies that the view can be added to the ViewSheet.
Public method Static member Create Creates a new Viewport at a given location on a sheet.
Public method GetBoxCenter Returns the center of the outline of the viewport on the sheet, excluding the viewport label.
Public method GetBoxOutline Returns the outline of the viewport on the sheet, excluding the viewport label.
Public method GetLabelOutline Gets the outline viewport's label on the sheet.
Public method GetProjectionToSheetTransform Returns the transform from the view's projection space to the sheet space.
Public method HasViewportTransforms Indicates if the viewport has transforms.
Public method IsViewIdValidForViewport Verifies that the Viewport can change it's view id to the input %viewId%.
Public method Code example SetBoxCenter Moves this viewport so that the center of the box outline (excluding the viewport label) is at a given point.
Top
Remarks
Viewports are used in Revit for purposes other than placement of views on sheets. Thus iteration of viewport elements in the model may locate viewports which are not assigned to sheets; you can use the SheetId property to filter these out.
See Also