LayoutRuleFixedNumber Class


Layout Rule Fixed Number Class

This class indicate the layout rule of a Beam System is Fixed-Number.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class LayoutRuleFixedNumber : LayoutRule

The LayoutRuleFixedNumber type exposes the following members.

Constructors
Name Description
Public method LayoutRuleFixedNumber Constructor of LayoutRuleFixedNumber.
Top
Properties
Name Description
Public property Code example IsReadOnly Identifies if the object is read-only or modifiable.
(Inherited from APIObject )
Public property NumberOfLines Get or set the number of the beams in a beam system.
Top
Methods
Name Description
Public method Dispose Causes the object to release immediately any resources it may be utilizing.
(Inherited from APIObject )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
Remarks
To use this type of LayoutRule, only the number of the beams must be set.
Example
private bool LayoutRuleFixedNumberInformation(BeamSystem beamSystem)
{
    //get the layoutRule of the beamsystem
    Autodesk.Revit.DB.LayoutRule layoutRule = beamSystem.LayoutRule;

    string message = "BeamSystem layout rule : " + layoutRule;

    //create a new instance of the LayoutRuleClearSpacing class 
    LayoutRuleFixedNumber myLayoutRuleFixedNumber =
                        new LayoutRuleFixedNumber(8);

    //set the new layoutRule to the beamsystem
    beamSystem.LayoutRule = myLayoutRuleFixedNumber;

    LayoutRuleFixedNumber fixedNumber = beamSystem.LayoutRule as LayoutRuleFixedNumber;

    if (null == fixedNumber)
    {
        return false;
    }
    //try to get the property value of the beamsystem LayoutRule
    int numberOfLines = fixedNumber.NumberOfLines;

    message += "\nNew BeamSystem layout rule: " + fixedNumber;
    message += "\nNew BeamSystem number of beams: " + numberOfLines;

    TaskDialog.Show("Revit",message);

    return true;
}
See Also