Create Method


MEPAnalytical Connection Type Create Method

Creates an analytical connection type element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static MEPAnalyticalConnectionType Create(
	Document doc,
	string name
)

Parameters

doc Document
The document.
name String
The name of the analytical type to be created.

Return Value

MEPAnalyticalConnectionType
The created analytical connection type element.
Exceptions
Exception Condition
ArgumentException This name is already used by an existing analytical connection type in the document. -or- name cannot include prohibited characters, such as "{, }, [, ], |, ;, less-than sign, greater-than sign, ?, `, ~". -or- name is an empty string.
ArgumentNullException A non-optional argument was null
Remarks
The newly created type would have the default pressure loss being 0. Use ElementType.duplicate to copy from any existing type.
See Also