Filtered |
Intersects the set of elements passing the filter in this collector with the set of elements passing the filter in another collector.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- other FilteredElementCollector
- The other collector
Return Value
FilteredElementCollectorA handle to this collector. This is the same collector that has just been modified, returned so you can chain multiple calls together in one line.

Exception | Condition |
---|---|
ArgumentException | The collector does not have a filter applied. Extraction or iteration of elements is not permitted without a filter. |
ArgumentNullException | A non-optional argument was null |
InvalidOperationException | The collector does not have a filter applied. Extraction or iteration of elements is not permitted without a filter. |

The result will be the same as using a LogicalAndFilter to connect this filter with another. If you have an active iterator to this collector it will be stopped by this call.