IsValidValue Method


Asset Property List Is Valid Value Method

Check that value is valid.

Namespace: Autodesk.Revit.DB.Visual
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool IsValidValue(
	IList<AssetProperty> value
)

Parameters

value IList AssetProperty
The array of properties to validate.

Return Value

Boolean
Returns true if the array of properties is valid, false otherwise.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
InvalidOperationException Cannot check validity for a property not being edited in AppearanceAssetEditScope.
See Also