DocumentSaveToCentralProgressChangedEventArgs Class


Document Save To Central Progress Changed Event Args Class

The event arguments used during the save to central phase of [!:Autodesk::Revit::ApplicationServices::Application::WorksharedOperationProgressChanged] .
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class DocumentSaveToCentralProgressChangedEventArgs : DataTransferProgressChangedEventArgs

The DocumentSaveToCentralProgressChangedEventArgs type exposes the following members.

Properties
Name Description
Public property Cancellable Indicates whether an event may be cancelled by an event delegate.
(Inherited from RevitAPIEventArgs )
Public property FailureDueToConflicts Indicates the 'save to central' failure is caused by submission conflicts, that is because another one finished saving to central first.
Public property FinishedSize The transferred data size, in bytes, since the last time this event was raised.
(Inherited from DataTransferProgressChangedEventArgs )
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from RevitAPIEventArgs )
Public property Location Full path of the central model which is to be operated.
(Inherited from WorksharedOperationProgressChangedEventArgs )
Public property RetryTimes The number of times Revit has tried to Save to Central." Its value is '0' at the first time.
Public property SaveToCentralFinished Indicates if current 'save to central' is finished.
Public property Speed Speed(bytes/second) in this event.
(Inherited from DataTransferProgressChangedEventArgs )
Public property Status Gets API event status, reflect current operation execution status.
(Inherited from WorksharedOperationProgressChangedEventArgs )
Public property TotalSize Total expected data size to transfer, in bytes.
(Inherited from DataTransferProgressChangedEventArgs )
Public property TransferMode Data transfer mode in this event.
(Inherited from DataTransferProgressChangedEventArgs )
Top
Methods
Name Description
Public method Dispose
(Inherited from RevitAPIEventArgs )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method IsCancelled Indicates whether the event is being cancelled.
(Inherited from RevitAPIEventArgs )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
Remarks
It is NOT recommended to do any time-consuming work when handling WorksharedOperationProgressChanged event. This can increase workshared operation time. Name correction - it is renamed from 'DocumentSaveToCentralProgessChangedEventArgs' released since 2017 Subscription Update.
See Also