DocumentSaveToCentralProgressChangedEventArgs Class


Document Save To Central Progress Changed Event Args Class

The event arguments used during the save to central phase of [!:Autodesk::Revit::ApplicationServices::Application::WorksharedOperationProgressChanged] .
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class DocumentSaveToCentralProgressChangedEventArgs : DataTransferProgressChangedEventArgs

The DocumentSaveToCentralProgressChangedEventArgs type exposes the following members.

Properties
Name Description
Public property FailureDueToConflicts Indicates the 'save to central' failure is caused by submission conflicts, that is because another one finished saving to central first.
Public property RetryTimes The number of times Revit has tried to Save to Central." Its value is '0' at the first time.
Public property SaveToCentralFinished Indicates if current 'save to central' is finished.
Top
Methods
Name Description
Top
Remarks
It is NOT recommended to do any time-consuming work when handling WorksharedOperationProgressChanged event. This can increase workshared operation time. Name correction - it is renamed from 'DocumentSaveToCentralProgessChangedEventArgs' released since 2017 Subscription Update.
See Also