Group |
An element representing a group of elements that may be placed many times in a project or family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The GroupType type exposes the following members.

Name | Description | |
---|---|---|
![]() | Groups | Retrieve a set of all the groups that have this type. |

Name | Description | |
---|---|---|
![]() | GetAvailableAttachedDetailGroupTypeIds | Returns the attached detail groups available for this element group type. |
![]() ![]() | LoadFrom | Replaces the group with the contents of the input file. |

Grouping elements is useful when you need to create entities that represent repeating layouts or are common to many building projects, such as hotel rooms, apartments, or repeating floors.

public void GetInfo_GroupType(GroupType groupType)
{
string message = "GroupType";
//Retrieve a set of all the groups that have this type.
foreach (Group group in groupType.Groups)
{
// Get GroupType group name
message = "\nThe group type name is : " + groupType.Name;
//Returns all the members of the group.
message += "\nThe types and ids of the group members are : ";
IList<ElementId> groupMembers = group.GetMemberIds();
foreach (ElementId memberId in groupMembers)
{
Element element = group.Document.GetElement(memberId);
// Get GroupType group element id
message += "\n\t" + element.GetType().Name + " : " + memberId.ToString();
}
}
TaskDialog.Show("Revit",message);
}