PostFailure Method


Failures Accessor Post Failure Method

Posts an additional failure message to be processed for the current transaction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void PostFailure(
	FailureMessage failure
)

Parameters

failure FailureMessage
Failure message to post.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
InvalidOperationException This FailuresAccessor is inactive (is used outside of failures processing).
Remarks
Should be used during failures processing instead of a similar method in a document class. Using method of the document class with the same name during failures processing is prohibited.
See Also