Transform |

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The TransformWithBoundary type exposes the following members.

Name | Description | |
---|---|---|
![]() | TransformWithBoundary | Constructs a new copy of the input TransformWithBoundary object. |

Name | Description | |
---|---|---|
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the TransformWithBoundary |
![]() | GetBoundary | Returns the boundary for the model space to view projection space transform. |
![]() | GetModelToProjectionTransform | Gets the model space to view projection space transform. |

Use the model-to-projection transform returned by GetModelToProjectionTransform to transform model points to the view's projection space. The model-to-projection transform is only valid for points in 3D model space that that can be seen through the 2D boundary returned by GetBoundary , when looking in the direction of [!:View.ViewDirection] .
For views that are placed on sheets, you can combine the View's model-to-projection transform and the Viewport's projection-to-sheet transform to transform model points to sheet space:
sheetXYZ = projectionToSheetTransform * modelToProjectionTransform * modelXYZ
Model space is the global 3D coordinate space in which the 3D geometry of the model lives.
View projection space is the 3D Euclidean space with a coordinate system such that X and Y are horizontal and vertical directions in the view projection plane and Z is the cross product of X and Y. Distances in the projection space are the same as would be measured on paper if the view is printed without additional scaling.
Sheet space is the coordinate space of one sheet. This is the space in which viewports and titleblocks are arranged on the sheet.