EditorInteractionType Enumeration


Editor Interaction Type Enumeration

Defines the type of interactions a pane has with the active editor when it becomes active in the Revit UI.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public enum EditorInteractionType
Members
Member name Value Description
Dismiss 0 Dismiss the active editor during pane activation. This results in the current selection being cleared and the editor canceled. One example built-in dockable pane that uses this mode is the Revit Project Browser.
KeepAlive 1 Keeps the active editor alive during pane activation. This results in the current selection being kept active and available to the pane. One example built-in dockable pane that uses this mode is the Revit Property Palette.
See Also