AreaLoad Class


Area Load Class

An object that represents a force applied across an area.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class AreaLoad : LoadBase

The AreaLoad type exposes the following members.

Properties
Name Description
Public property Area Returns area of the area load.
Public property ForceVector1 The force vector applied to the 1st reference point of the area load, oriented according to OrientTo setting.
Public property ForceVector2 The force vector applied to the 2nd reference point of the area load, oriented according to OrientTo setting.
Public property ForceVector3 The force vector applied to the 3rd reference point of the area load, oriented according to OrientTo setting.
Public property IsProjected Indicates if the load is projected.
Public property NumRefPoints Returns the total number of reference points for the area load.
Top
Methods
Name Description
Public method Static member AreCurveLoopsValid Checks if curve loops are valid for creating an area load.
Public method Static member Create(Document, ElementId, XYZ, AreaLoadType) Creates a new hosted area load within the project.
Public method Static member Create(Document, ElementId, IList CurveLoop , XYZ, AreaLoadType) Creates a new custom area load within the project.
Public method Static member Create(Document, ElementId, IList CurveLoop , IList XYZ , IList Int32 , IList Int32 , AreaLoadType) Creates a new custom area load within the project.
Public method GetLoops Returns curve loops that define geometry of the area load.
Public method GetRefPoint Returns the physical location of the reference point.
Public method Static member IsCurveLoopsInsideHostBoundaries Checks if contour loops is inside host boundaries.
Public method Static member IsValidHostId Indicates if the provided host id can host area loads The document containing both the host and the load The id of the analytical element that is about to host an area load True if an area load can be placed on the input host id
Public method SetLoops Sets curve loops that define geometry of the area load.
Top
Example
public void GetInfo_AreaLoad(AreaLoad areaLoad)
{
    string message = "AreaLoad Force : ";
    // Get areaload force1 position
    message += "\nAreaLoad Force1 position :(" + areaLoad.ForceVector1.X + ", "
        + areaLoad.ForceVector1.Y + ", " + areaLoad.ForceVector1.Z + ")";
    // Get areaload force2 position
    message += "\nAreaLoad Force2 position :(" + areaLoad.ForceVector2.X + ", "
        + areaLoad.ForceVector2.Y + ", " + areaLoad.ForceVector2.Z + ")";
    // Get areaload force3 position
    message += "\nAreaLoad Force3 position :(" + areaLoad.ForceVector3.X + ", "
        + areaLoad.ForceVector3.Y + ", " + areaLoad.ForceVector3.Z + ")";

    // Get Loops
    int loopIndex = 0;
    foreach (CurveLoop curveLoop in areaLoad.GetLoops())
    {
       message += "\nLoop " + loopIndex + " consist of following points :";
       foreach (Curve curve in curveLoop)
       {
          message += " (" + curve.GetEndPoint(0).X + ", " + curve.GetEndPoint(0).Y + ", " + curve.GetEndPoint(0).Z + ")";
       }
       loopIndex++;
    }

    // Get ref points information
    for (int k = 0; k < areaLoad.NumRefPoints; k++)
    {
        // Get areaload Ref point
        message += "\nAreaLoad Ref point :(" + areaLoad.GetRefPoint(k).X + ", "
            + areaLoad.GetRefPoint(k).Y + ", " + areaLoad.GetRefPoint(k).Z + ")";
    }
    TaskDialog.Show("Revit",message);
}
See Also