Application Class


Application Class

The Application Creation object is used to create new instances of utility objects.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB APIObject
Autodesk.Revit.Creation Application

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class Application : APIObject

The Application type exposes the following members.

Properties
Name Description
Top
Methods
Name Description
Public method NewAreaCreationData Creates an object which wraps the arguments of Area for batch creation.
Public method NewBoundingBoxUV Creates an empty two-dimensional rectangle.
Public method NewBoundingBoxUV(Double, Double, Double, Double) Creates a two-dimensional rectangle with supplied values.
Public method NewBoundingBoxXYZ Creates a three-dimensional rectangular box.
Public method NewCategorySet Creates a new instance of a set specifically for holding category objects.
Public method Code example NewColor Returns a new color object.
Public method NewCombinableElementArray Returns an array that can hold combinable element objects.
Public method NewCurveArrArray Creates an empty array that can store geometric curve loops.
Public method NewCurveArray Creates an empty array that can store geometric curves.
Public method NewCurveLoopsProfile Creates a new CurveLoopsProfile object.
Public method NewDoubleArray Creates a new instance of a double array.
Public method NewDWFExportOptions Creates DWF Export options.
Public method NewDWFXExportOptions Creates DWFX Export options.
Public method NewElementId Creates a new Autodesk::Revit::DB::ElementId^ object.
Public method NewElementSet Creates a new instance of a set specifically for holding elements.
Public method NewFaceArray Creates a new instance of a face array.
Public method NewFamilyInstanceCreationData(FamilySymbol, IList XYZ ) Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
Public method NewFamilyInstanceCreationData(Face, Line, FamilySymbol) Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
Public method NewFamilyInstanceCreationData(XYZ, FamilySymbol, StructuralType) Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
Public method NewFamilyInstanceCreationData(Curve, FamilySymbol, Level, StructuralType) Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
Public method NewFamilyInstanceCreationData(Face, XYZ, XYZ, FamilySymbol) Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
Public method NewFamilyInstanceCreationData(XYZ, FamilySymbol, Element, StructuralType) Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
Public method NewFamilyInstanceCreationData(XYZ, FamilySymbol, Level, StructuralType) Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
Public method NewFamilyInstanceCreationData(XYZ, FamilySymbol, Element, Level, StructuralType) Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
Public method NewFamilyInstanceCreationData(XYZ, FamilySymbol, XYZ, Element, StructuralType) Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
Public method NewFamilySymbolProfile Creates a new FamilySymbolProfile object.
Public method NewFBXExportOptions Creates 3D-Studio Max (FBX) Export options.
Public method NewGBXMLImportOptions Creates Green-Building XML Import options.
Public method Code example NewGeometryOptions Creates an object to specify user preferences in parsing of geometry.
Public method NewInstanceBinding Creates a new empty instance binding object.
Public method NewInstanceBinding(CategorySet) Creates a new instance binding object containing the categories passed as a parameter.
Public method NewIntersectionResultArray Creates a new instance of an IntersectionResult array.
Public method NewPointOnEdge Create a PointOnEdge object which is used to define the placement of a ReferencePoint.
Public method NewPointOnEdgeEdgeIntersection Construct a PointOnEdgeEdgeIntersection object which is used to define the placement of a ReferencePoint given two references to edge.
Public method NewPointOnEdgeFaceIntersection Construct a PointOnEdgeFaceIntersection object which is used to define the placement of a ReferencePoint given a references to edge and a reference to face.
Public method NewPointOnFace Construct a PointOnFace object which is used to define the placement of a ReferencePoint given a reference and a location on the face.
Public method NewPointOnPlane Construct a PointOnPlane object which is used to define the placement of a ReferencePoint from its property values.
Public method NewPointRelativeToPoint Create a PointRelativeToPoint object, which is used to define the placement of a ReferencePoint relative to a host point.
Public method NewProjectPosition Creates a new project position object.
Public method NewReferenceArray Creates a new instance of a reference array.
Public method NewReferencePointArray Creates an empty array that can store ReferencePoint objects.
Public method NewSpaceSet Creates a new instance of a space set.
Public method NewTypeBinding Creates a new empty type binding object.
Public method NewTypeBinding(CategorySet) Creates a new type binding object containing the categories passed as a parameter.
Public method NewUV Creates a UV object at the origin.
Public method NewUV(UV) Creates a UV object by copying the supplied UV object.
Public method NewUV(Double, Double) Creates a UV object representing coordinates in 2-space with supplied values.
Public method NewVertexIndexPair Creates a new VertexIndexPair object.
Public method NewVertexIndexPairArray Returns an array that can hold VertexIndexPair objects.
Public method NewViewSet Creates a new instance of a View set.
Public method NewXYZ Creates a XYZ object at the origin.
Public method NewXYZ(XYZ) Creates a XYZ object by copying the supplied XYZ object.
Public method NewXYZ(Double, Double, Double) Creates a XYZ object representing coordinates in 3-space with supplied values.
Top
Remarks
General purpose objects can be generated by this creation object. Creating objects via this object ensures that they will be correctly constructed and will reside in the Autodesk Revit memory space.
See Also