NewRadialDimension Method (View, Reference, XYZ)


Family Item Factory New Radial Dimension(View, Reference, XYZ) Method

Creates a new radial dimension object using the default dimension type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public Dimension NewRadialDimension(
	View view,
	Reference arcRef,
	XYZ origin
)

Parameters

view View
The view in which the dimension is to be visible.
arcRef Reference
Geometric reference of the arc to which the dimension is to be bound.
origin XYZ
The point where the witness line of the radial dimension will lie.

Return Value

Dimension
If creation was successful the new arc length dimension is returned, otherwise an exception with failure information will be thrown.
Exceptions
Exception Condition
ArgumentNullException Thrown when any input argument is .
ArgumentException Thrown when the argument arcRef is invalid.
InvalidOperationException Thrown when the creation failed.
Remarks
The currently user set default style is used for the created dimension.
See Also