Sun |
Identifies the sunrise time for the SunAndShadowSettings element at its current location and indicated date.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- date DateTime
- The date for which to determine sunrise time.
Return Value
DateTimeThe date and time. The value will be in Coordinated Universal Time (UTC).

The value returned is affected by the value of the UsesDST flag set for the current location. If this value is true, the sunrise value will be adjusted for Daylight Savings Time, regardless of the value of the input date.