GetRoofComponents Method


Exporter IFCUtils Get Roof Components Method

Gets the components of roof slabs.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static RoofComponents GetRoofComponents(
	ExporterIFC exporterIFC,
	RoofBase roof
)

Parameters

exporterIFC ExporterIFC
The exporter.
roof RoofBase
The roof element.

Return Value

RoofComponents
The roof components.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also