ConstructionType Enumeration


Construction Type Enumeration

This enumeration specifies the available analytical construction types like external walls, windows etc. for use in the detailed analytical energy model.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public enum ConstructionType
Members
Member name Value Description
ExteriorWall 0 An exterior wall surrounding the space
InteriorWall 1 An interior wall surrounding the space
Slab 2 A slab below the space
Roof 3 A roof over the space
Ceiling 4 A ceiling over the space
Floor 5 A floor below the space
Door 6 A door in a wall in the space
ExteriorWindow 7 A window in an exterior wall in the space
InteriorWindow 8 A window in an interior wall in the space
Skylight 9 A window in a roof in the space
UndergroundWall 10 Underground walls
See Also