Conceptual |
Indicates if this ConceptualConstructionType is appropriate for the input MassSurfaceData subcategory.
Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public bool IsValidSurfaceSubcategoryForConstruction(
ElementId massSurfaceSubcategoryId
)
Parameters
- massSurfaceSubcategoryId ElementId
- The ElementId of a Mass subcategory of a MassSurfaceData.
Return Value
BooleanReturns true if appropriate for the input subcategory, false otherwise.

Exception | Condition |
---|---|
ArgumentException | The input Element massSurfaceSubcategoryId is not a valid subcategory value for MassSurfaceData. |
ArgumentNullException | A non-optional argument was null |