OrientTo Method


View 3D Orient To Method

Reorients the view to align with the forward direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void OrientTo(
	XYZ forwardDirection
)

Parameters

forwardDirection XYZ
The forward direction.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException forwardDirection has zero length.
InvalidOperationException View is locked and cannot be reoriented.
Remarks
This method adjusts the ViewOrientation to align with the input forward direction. The eye position will be automatically determined based on the shape of the viewing area and size of the model. The UpDirection will be aligned with the project Z axis.
See Also