BuiltInFailures.RoofFailures Class


Built In Failures Roof Failures Class

Failures about Roof.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB BuiltInFailures RoofFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class RoofFailures

The BuiltInFailures RoofFailures type exposes the following members.

Properties
Name Description
Public property Static member CurveRoofSkippedLoops Some loops were skipped
Public property Static member CurveRoofSkippedLoopsError Some loops were skipped
Public property Static member CurveRoofSkippedLoopsWarn Some loops were skipped
Public property Static member ExtrudedRoofCutBySketch Entire extruded Roof is cut by cut Sketch.
Public property Static member HadToAlignEaves Adjacent slope-defining lines must have identical eave heights. Eaves were aligned to higher location automatically to avoid failure. Use the Align Eaves tool to specify desired location.
Public property Static member HoleInRoofFailed Hole(s) could not be cut in roof.
Public property Static member InvalidArcSegmentation A segmented slope-defining arc has too few segments.
Public property Static member JoinedRoofMissesTarget Part of the roof to be joined misses the target face.
Public property Static member JoinedRoofMissesTargetError Part of the roof to be joined misses the target face.
Public property Static member NoFlatCurtainRoofs A Sloped Glazing with no slope is not allowed.
Public property Static member OnlyOneSlopeCurtainRoof Only one slope in curtain roof.
Public property Static member OnlyUpwardFacesUsed The selected faces contain both upward and downward pointing faces. Only the upward pointing faces were used.
Public property Static member RoofCutoffRemoved The roof's cutoff failed and was removed; make sure the cutoff height is not below the roof.
Public property Static member RoofExceedsMaxHeight Roof exceeds user-specified maximum height
Public property Static member RoofMeetsRoofTangentially The roofs cannot be joined because the roof being joined meets the target roof tangentially.
Public property Static member RoofMeetsRoofTangentiallyError The roofs cannot be joined because the roof being joined meets the target roof tangentially.
Public property Static member RoofSlopeExceedsThreshold Thickness of this Roof may be slightly inaccurate due to extreme Shape Editing. Dimensions to this element in sections and details may not accurately indicate the Thickness shown in Type Properties.
Public property Static member RoofToRefPlanes Roof cannot be joined to more than one reference plane.
Public property Static member RoofToRefPlanesError Roof cannot be joined to more than one reference plane.
Public property Static member UnusedSlopeArrow The tails of all slope arrows must lie on the roof boundary.
Public property Static member UptoHeightTooLow Cutoff Level cannot be below bottom of roof.
Public property Static member UserCancelledRoof Cancelled.
Public property Static member WorkplaneShouldBeLevel Can't use Workplane that is not a Level. Set the desired Level as current Workplane.
Top
See Also