FindEndsOfShortestPaths Method


Path Of Travel Find Ends Of Shortest Paths Method

For a floor plan view, calculates the paths from each start point to its closest destination and return the path end points.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static IList<XYZ> FindEndsOfShortestPaths(
	View DBView,
	IList<XYZ> destinationPoints,
	IList<XYZ> startPoints
)

Parameters

DBView View
The floor plan view to use when computing the points.
destinationPoints IList XYZ
Destination points. The input Z coordinates are ignored and set to the view's level elevation.
startPoints IList XYZ
Start points for which shortest path end points are calculated.

Return Value

IList XYZ
End points of paths calculated from each start point to its corresponding closest destination. If a path cannot be calculated the corresponsing end point is set to the corresponding start point.
Exceptions
Exception Condition
ArgumentException View is not a floor plan view.
ArgumentNullException A non-optional argument was null
InvalidOperationException The Path of Travel calculation service is not available -or- This functionality is not available in Revit LT.
Remarks
The calculation is done in a floor plan with one or more destinationPoints and one or more startPoints. The shortest path is calculated from each start point to its corresponding closest destination.
See Also