BoundingBoxIntersectsFilter Constructor (Outline, Boolean)


Bounding Box Intersects Filter(Outline, Boolean) Constructor

Constructs a new instance of a filter to match elements with a bounding box that intersects the given Outline, with the option to invert the filter and match all elements with a bounding box that are not intersecting the given Outline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public BoundingBoxIntersectsFilter(
	Outline outline,
	bool inverted
)

Parameters

outline Outline
The Outline used to find elements with a bounding box that intersect it.
inverted Boolean
True if the filter should be inverted and match all elements with a bounding box that are not intersecting the given Outline.
Exceptions
Exception Condition
ArgumentException outline is an empty Outline.
ArgumentNullException A non-optional argument was null
See Also