ApplicationClosing Event


UIApplication Application Closing Event

Subscribe to the ApplicationClosing event to be notified when the Revit application is just about to be closed.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public event EventHandler<ApplicationClosingEventArgs> ApplicationClosing

Value

EventHandler ApplicationClosingEventArgs
Remarks

This event is raised when the Revit application is just about to be closed.

Event is not cancellable. The 'Cancellable' property of event's argument is always False.

No document may be modified at the time of the event.

The sender object of this event is UIControlledApplication object.

See Also