CreateSubDivision Method


Toposolid Create Sub Division Method

Create a toposolid subdivision element with the current toposolid as its host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public Toposolid CreateSubDivision(
	Document document,
	IList<CurveLoop> profiles
)

Parameters

document Document
The document in which the new toposolid is created.
profiles IList CurveLoop
An array of planar curve loops that represent the profiles of the toposolid.

Return Value

Toposolid
The toposolid subdivision object.
Exceptions
Exception Condition
ArgumentException The input curve loops cannot compose a valid boundary, that means: the "curveLoops" collection is empty; or some curve loops intersect with each other; or each curve loop is not closed individually; or each curve loop is not planar; or each curve loop is not in a plane parallel to the horizontal(XY) plane; or input curves contain at least one helical curve.
ArgumentNullException A non-optional argument was null
See Also