Item |
Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public FamilyInstance NewFamilyInstance(
XYZ location,
FamilySymbol symbol,
Element host,
StructuralType structuralType
)
Parameters
- location XYZ
- The physical location where the instance is to be placed.
- symbol FamilySymbol
- A FamilySymbol object that represents the type of the instance that is to be inserted.
- host Element
- The object into which the FamilyInstance is to be inserted, often known as the host.
- structuralType StructuralType
- If structural then specify the type of the component.
Return Value
FamilyInstanceIf creation was successful then an instance to the new object is returned, otherwise .

Exception | Condition |
---|---|
ArgumentException | Thrown if The symbol is not active. |

The type/symbol that is used must be loaded into the document before this method is called. Families and their symbols can be loaded using the Document.LoadFamily or Document.LoadFamilySymbol methods.
The host object must be one that supports insertion of instances otherwise this method will fail.
Some Families, such as Beams, have more than one endpoint and are inserted in the same manner as single point instances. Once inserted these linear family instances can have their endpoints changed by using the instance's Element.Location property.
Note: ForbiddenForDynamicUpdateException might be thrown during a dynamic update if the inserted instance establishes a mutual dependency with another structure.
Note: if the created family instance includes nested instances, the API framework will automatically regenerate the document during this method call.

Wall CreateWallWithWindows(Autodesk.Revit.DB.Document document, Level level)
{
// Create a new wall
// Build a location line for the wall creation
XYZ start = new XYZ(0, 0, 0);
XYZ end = new XYZ(10, 10, 0);
Line wallLine = Line.CreateBound(start, end);
// Create a wall using the location line
Wall newWall = Wall.Create(document, wallLine, level.Id, true);
// Find a Window type for the new windows
FilteredElementCollector winCollector = new FilteredElementCollector(document);
IList<Element> windowTypes = winCollector.OfCategory(BuiltInCategory.OST_Windows).WhereElementIsElementType().ToElements();
FamilySymbol winType = windowTypes.First() as FamilySymbol;
// put 3 windows in the wall
double x = 2, y = 2, z = 2;
for (int i = 0; i < 3; i++)
{
XYZ location = new XYZ(x, y, z);
FamilyInstance instance = document.Create.NewFamilyInstance(location, winType, newWall, StructuralType.NonStructural);
x += 3;
y += 3;
}
return newWall;
}