GetMainEnergyAnalysisDetailModel Method


Energy Analysis Detail Model Get Main Energy Analysis Detail Model Method

Gets the EnergyAnalysisDetailModel in given document.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static EnergyAnalysisDetailModel GetMainEnergyAnalysisDetailModel(
	Document document
)

Parameters

document Document
The document that contains the physical model of the building.

Return Value

EnergyAnalysisDetailModel
Returns the EnergyAnalysisDetailModel contained in the document, if it exists. If it does not exist, this returns .
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also