ConicalFace Class


Conical Face Class

A conical face of a 3d solid or open shell.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ConicalFace : Face

The ConicalFace type exposes the following members.

Properties
Name Description
Public property Axis Axis of the surface.
Public property HalfAngle Half angle of the surface.
Public property Origin Origin of the surface.
Public property Radius Radii of the surface.
Top
Methods
Name Description
Top
Remarks
For details on the parameterization, refer to the documentation for ConicalSurface .
Example
private void GetConicalFaceInfo(Face face)
{
    ConicalFace conicalFace = face as ConicalFace;
    if (null != conicalFace)
    {
       XYZ axis = conicalFace.Axis;
       XYZ origin = conicalFace.Origin;
        double halfAngle = conicalFace.HalfAngle;
        XYZ radius = conicalFace.get_Radius(0);
    }
}
See Also