BuiltInFailures.CreationFailures Class


Built In Failures Creation Failures Class

Failures about CreationFailures.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB BuiltInFailures CreationFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class CreationFailures

The BuiltInFailures CreationFailures type exposes the following members.

Properties
Name Description
Public property Static member CannotCreateCornice Could not create Wall Sweep. [Description]
Public property Static member CannotCreateCorniceError Could not create Wall Sweep. [Description]
Public property Static member CannotCreateCorniceIntegral Could not create integral wall sweep for wall instance. [Description]
Public property Static member CannotCreateCorniceIntegralError Could not create integral wall sweep for wall instance. [Description]
Public property Static member CannotCreateCorniceIntegralWarn Could not create integral wall sweep for wall instance. [Description]
Public property Static member CannotCreateCorniceWarn Could not create Wall Sweep. [Description]
Public property Static member CannotCreateCurtainGrid Can't create Curtain Wall Grid Line.
Public property Static member CannotCreateCutout Can't make cut-out.
Public property Static member CannotCreateCutoutError Can't make cut-out.
Public property Static member CannotCreateCutoutWarn Can't make cut-out.
Public property Static member CannotCreateElementInFamily Can't create element in this family.
Public property Static member CannotCreateElementInView Can't create this kind of element in this view in the current mode.
Public property Static member CannotCreateExplicitCrease Cannot create a new split line based on the picked support.
Public property Static member CannotCreateFascia Could not create Fascia. [Description]
Public property Static member CannotCreateFasciaError Could not create Fascia. [Description]
Public property Static member CannotCreateFasciaWarn Could not create Fascia. [Description]
Public property Static member CannotCreateGutter Could not create Gutter. [Description]
Public property Static member CannotCreateGutterError Could not create Gutter. [Description]
Public property Static member CannotCreateGutterWarn Could not create Gutter. [Description]
Public property Static member CannotCreateMullion Can't create Mullion.
Public property Static member CannotCreateMullionError Can't create Mullion.
Public property Static member CannotCreateMullionReference Can't create Curtain Wall Mullion. The grid segment for the Mullion is probably too small.
Public property Static member CannotCreateMullionReferenceNoGeometry Can't create Curtain Wall Mullion. The portion of the curtain grid it was placed on no longer exists.
Public property Static member CannotCreateNewDesignOption Cannot create a new empty design option
Public property Static member CannotCreateOldCornerMullion Cannot change the type of a mullion created prior to release 4.0 to a corner mullion type. Try deleting the existing mullion and placing a new one.
Public property Static member CannotCreateOpening Cannot create opening.
Public property Static member CannotCreateOpeningCutOut Can't create Opening cut.
Public property Static member CannotCreateOpeningRectangularArcWall Creation of a Rectangular Arc Wall Opening failed.
Public property Static member CannotCreateReveal Could not create Reveal. [Description]
Public property Static member CannotCreateRevealError Could not create Reveal. [Description]
Public property Static member CannotCreateRevealIntegral Could not create integral reveal for wall instance. [Description]
Public property Static member CannotCreateRevealIntegralError Could not create integral reveal for wall instance. [Description]
Public property Static member CannotCreateRevealIntegralWarn Could not create integral reveal for wall instance. [Description]
Public property Static member CannotCreateRevealWarn Could not create Reveal. [Description]
Public property Static member CannotCreateSlabEdge Could not create Slab Edge. [Description]
Public property Static member CannotCreateSlabEdgeError Could not create Slab Edge. [Description]
Public property Static member CannotCreateSlabEdgeWarn Could not create Slab Edge. [Description]
Public property Static member CannotCreateSlantedWallWithSingularLayers Cannot create wall - its layers would degenerate or intersect. Reduce the wall's height or slant.
Public property Static member CannotCreateSlantedWallWithSingularLayersError Cannot create wall - its layers would degenerate or. Reduce the wall's height or slant.
Public property Static member CannotCreateSystemPanel Can't create Curtain Panel in opening. The opening is probably too small.
Public property Static member CannotCreateTaperedWallForWallType Cannot create tapered wall - the Wall Type is unacceptable. Be sure to choose a variable-thickness layer in the Wall Type.
Public property Static member CannotCreateTaperedWallForWallTypeError Cannot create tapered wall - the Wall Type is unacceptable. Be sure to choose a variable-thickness layer in the Wall Type.
Public property Static member CannotCreateThis Can't create [Element].
Public property Static member CannotDrawProfileRoof Can't make footprint roof.
Public property Static member CannotDrawRoof Can't make roof.
Public property Static member CannotDrawRoofError Can't make roof.
Public property Static member CannotDrawRoofWall Can't make roof.
Public property Static member CannotDrawSingularSlantedWall Cannot create wall - it would intersect itself. Reduce the wall's height or slant.
Public property Static member CannotDrawSingularSlantedWallError Cannot create wall - it would intersect itself. Reduce the wall's height or slant.
Public property Static member CannotDrawToposolid Can't make toposolid.
Public property Static member CannotDrawToposolidError Can't make toposolid.
Public property Static member CannotDrawWalls Can't make Wall.
Public property Static member CannotDrawWallsError Can't make Wall.
Public property Static member CannotMakeRoofFromVerticalFace Can't make roof from vertical face.
Public property Static member CannotMakeRoofFromVerticalFaceError Can't make roof from vertical face.
Public property Static member CannotMakeSurface Can't construct surface.
Public property Static member CannotMakeSurfaceError Can't construct surface.
Public property Static member CannotMakeSurfaceWarn Can't construct surface.
Public property Static member CannotMakeToposolid Can't construct toposolid.
Public property Static member CannotMakeToposolidFromVerticalFace Can't make toposolid from vertical face.
Public property Static member CannotMakeToposolidFromVerticalFaceError Can't make toposolid from vertical face.
Public property Static member CannotMakeWall Can't make Wall.
Public property Static member CannotUpdateWall Can't update Wall.
Public property Static member SwitchFromLegendBeforeCreateSimilar To Create Similar from a Legend View, first select the element, then activate the target view, then invoke Create Similar.
Top
See Also