AddUpdatingSharedParameter Method


Rebar Free Form Accessor Add Updating Shared Parameter Method

Add existing shared parameter as a dependency for the calculation of the rebar curves.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void AddUpdatingSharedParameter(
	ElementId parameterId
)

Parameters

parameterId ElementId
ElementId of the shared parameter to be added.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
InvalidOperationException This RebarFreeFormAccessor Rebar doesn't contain a valid server GUID. -or- parameterId is a parameter that is not bound to the Rebar element category.
Remarks

The input parameter needs to be bound to the Rebar element

The rebar element needs to have a valid external server

See Also