Element Delete |
Removes the subelements from the element.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- subelems IList Subelement
- Subelements to delete.
Return Value
BooleanTrue if entire element was deleted, false otherwise.

Exception | Condition |
---|---|
ArgumentException | One or more subelements in subelems do not exist in the element. -or- One or more of the subelements subelems cannot be deleted. |
ArgumentNullException | A non-optional argument was null |
ModificationForbiddenException | This Element is an internal element, such as a component of a loaded family or a group type. -or- The document containing this Element is in Group Edit Mode, Sketch Edit Mode, or Paste Mode, and the element is not a member of the group, sketch, or clipboard. -or- This Element is a member of a group or sketch, and the document is not currently editing the group or sketch. |

Depending on implementation for given element as the result, the element can be deleted - especially if after Subelement deletion there are no Subelement left. See also: IsModifiable .