TopographySurface Class


Topography Surface Class

Represents a TopographySurface element.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB Element
Autodesk.Revit.DB.Architecture TopographySurface

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class TopographySurface : Element

The TopographySurface type exposes the following members.

Properties
Name Description
Public property ArePointsEditable Identifies whether the points of this topography surface can be edited independently. Topography surfaces created from external data will not allow editing of individual points.
Public property AssociatedBuildingPadId The element id of the building pad which causes this topography surface to be formed.
Public property IsAssociatedWithBuildingPad Identifies if this element represents a topography surface associated with a building pad.
Public property IsSiteSubRegion Identifies if this element represents a subregion.
Public property MaterialId The id of the material applied to this element.
Top
Methods
Name Description
Public method AddPoints Obsolete.
Adds points to a topography surface.
Public method Static member ArePointsDistinct Identify whether the input points are distinct in XY location.
Public method AsSiteSubRegion Obtains the subregion object represented by this element.
Public method ChangePointElevation Obsolete.
Changes the elevation value for a point.
Public method ChangePointsElevation Obsolete.
Changes the elevation value for points
Public method ContainsPoint Identifies whether the given point exists in the topography surface.
Public method Static member Create(Document, IList XYZ ) Obsolete.
Creates a new topography surface element and adds it to the document.
Public method Static member Create(Document, IList XYZ , IList PolymeshFacet ) Obsolete.
Creates a new topography surface element from facets and adds it to the document.
Public method DeletePoints Obsolete.
Deletes points from a Topography surface.
Public method FindPoints Filters and returns only the points of the topography surface which lie within the input bounding box.
Public method GetBoundaryPoints Gets the points which are on the boundary of the topography surface.
Public method GetHostedSubRegionIds Gets the ids of all subregion elements hosted on this topography surface.
Public method GetInteriorPoints Gets all of the points that are not boundary points for the topography surface.
Public method GetPoints Gets the points that define this topography surface.
Public method IsBoundaryPoint Identifies whether the given point is an existing boundary point of the current topography surface.
Public method Static member IsValidFaceSet Identifies whether the facets can construct a valid topography surface.
Public method Static member IsValidRegion Identify whether the points can construct a valid region for a topography surface.
Public method MovePoint Obsolete.
Moves a point in a TopographySurface to a new designated location.
Public method MovePoints Obsolete.
Moves a collection of points in a topography surface by a designated vector.
Top
Remarks
TopographySurface and related classes have been replaced as of Revit 2024 with Toposolid and related classes. It is recommended that all newly created elements and modifications operate from the new Toposolid class. The TopographySurface element remains in the API for backwards compatibility and upgrade. A TopographySurface element in the Revit API represents:
  • An actual topography surface which can have an arbitrary boundary and collection of points.
  • A SiteSubRegion element bounded by a sketch.
  • A topography surface created automatically by the introduction of a BuildingPad element.
Identify a subregion with the IsSiteSubRegion property, and access the object that provides interfaces to manipulate the subregion via AsSiteSubRegion(). Identify a topography surface associated with a building pad with the isAssociatedWithBuildingPad property, and access the associated BuildingPad element via the property AssociatedBuildingPadId. If the element does represent a subregion or a topography surface associated with a building pad, some methods of this class are inapplicable.
See Also