MEPAnalytical |
Represents an analytical segment of the MEP analytical model.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The MEPAnalyticalSegment type exposes the following members.

Name | Description | |
---|---|---|
![]() | Area | The area of the segment profile. |
![]() | DemandFlow | The designed flow value, in ft^3/s. |
![]() | DomainType | The connector domain type of this segment. |
![]() | EndNode | The id of the end analytical node. |
![]() | Id | The identity of this segment. |
![]() | InnerDiameter | The inner diameter of this segment, in ft. For rectangular or oval profile, this may be the hydraulic diameter. |
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |
![]() | RevitElementId | The id of the owning Revit element. |
![]() | Roughness | The roughness of this segment, in ft. |
![]() | SegmentType | The analytical segment type. |
![]() | StartNode | The id of the start analytical node. |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the MEPAnalyticalSegment |
![]() | GetNetworkSegmentId | Gets the NetworkSegmentId. |