SharedParameterApplicableRule Class


Shared Parameter Applicable Rule Class

Tests whether an element supports a shared parameter.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB FilterRule
Autodesk.Revit.DB SharedParameterApplicableRule

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class SharedParameterApplicableRule : FilterRule

The SharedParameterApplicableRule type exposes the following members.

Constructors
Name Description
Public method SharedParameterApplicableRule Constructs an instance of SharedParameterApplicableRule.
Top
Properties
Name Description
Public property ParameterName The name of the parameter that an element must support to pass this rule.
Top
Methods
Name Description
Top
See Also