Rebar Get |
A chain of curves representing the centerline of the rebar.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public IList<Curve> GetTransformedCenterlineCurves(
bool adjustForSelfIntersection,
bool suppressHooks,
bool suppressBendRadius,
MultiplanarOption multiplanarOption,
int barPositionIndex
)
Parameters
- adjustForSelfIntersection Boolean
- If the curves overlap, as in a planar stirrup, this parameter controls whether they should be adjusted to avoid intersection (as in fine views), or kept in a single plane for simplicity (as in coarse views).
- suppressHooks Boolean
- Identifies if the chain will include hooks curves.
- suppressBendRadius Boolean
- Identifies if the connected chain will include unfilleted curves.
- multiplanarOption MultiplanarOption
- If the Rebar is a multi-planar shape, this parameter controls whether to generate only the curves in the primary plane (IncludeOnlyPlanarCurves), or to generate all curves, (IncludeAllMultiplanarCurves) including the out-of-plane connector segments as well as multi-planar copies of the primary plane curves. This argument is ignored for planar shapes.
- barPositionIndex Int32
- The bar index.
Return Value
IList CurveThe centerline curves or empty array if the curves cannot be computed because the parameters values are inconsistent with the constraints of the RebarShape definition.

Exception | Condition |
---|---|
ArgumentOutOfRangeException | barPositionIndex is not in the range [ 0, NumberOfBarPositions-1 ]. -or- A value passed for an enumeration argument is not a member of that enumeration |

This method will return the centerline curves for bar at barPositionIndex even if this bar isn't included. The curves are in the final position. The BarPositionTransform (representing the relative position of any individual bar in the set - a translation along the distribution path) and MovedBarTransform (representing the movement of the bar relative to its default position along the distribution path) will be applied to the returned curves.