Structural |
The base class for StructuralSection specific classes, designed to provide common parameters and ability to differentiate between different structural section shapes.

System Object
Autodesk.Revit.DB.Structure.StructuralSections StructuralSection
Autodesk.Revit.DB.Structure.StructuralSections StructuralSectionRectangular
Autodesk.Revit.DB.Structure.StructuralSections StructuralSectionRound
Autodesk.Revit.DB.Structure.StructuralSections StructuralSection
Autodesk.Revit.DB.Structure.StructuralSections StructuralSectionRectangular
Autodesk.Revit.DB.Structure.StructuralSections StructuralSectionRound
Namespace: Autodesk.Revit.DB.Structure.StructuralSections
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The StructuralSection type exposes the following members.

Name | Description | |
---|---|---|
![]() | AnalysisParams | Common set of parameters for structural analysis. |
![]() | ElasticModulusStrongAxis | Elastic section modulus about main strong axis for calculation of bending stresses. |
![]() | ElasticModulusWeakAxis | Elastic section modulus about main weak axis for calculation of bending stresses. |
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |
![]() | MomentOfInertiaStrongAxis | Moment of Inertia about main strong axis (I). |
![]() | MomentOfInertiaWeakAxis | Moment of Inertia about main weak axis (I). |
![]() | NominalWeight | Unit weight (not mass) per unit length, for self-weight calculation or quantity survey. |
![]() | Perimeter | Painting surface of the unit length. |
![]() | PlasticModulusStrongAxis | Plastic section modulus in bending about main strong axis (Z, Wpl). |
![]() | PlasticModulusWeakAxis | Plastic section modulus in bending about main weak axis. |
![]() | PrincipalAxesAngle | Rotation angle between the principal axes and cross section reference planes. |
![]() | SectionArea | Cross section area. |
![]() | SectionNameKey | A parameter in structural families which allows for family type identification. This will be used for data mapping during model exchange with another program, namely Advance Steel. |
![]() | ShearAreaStrongAxis | Shear area (reduced extreme shear stress coefficient) in the direction of strong axis (Wq). |
![]() | ShearAreaWeakAxis | Shear area (reduced extreme shear stress coefficient) in the direction of weak axis (Wq). |
![]() | StructuralSectionGeneralShape | The general type of structural section shape. |
![]() | StructuralSectionShape | The type of structural section shape. |
![]() | StructuralSectionShapeName | A human readable string representing the structural section shape. |
![]() | TorsionalModulus | Section modulus for calculations of torsion stresses (Ct). |
![]() | TorsionalMomentOfInertia | Torsional Moment of inertia (J, IT, K), for calculation of torsional deformation |
![]() | WarpingConstant | Warping constant (Cw, Iomega, H). |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the StructuralSection |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetBoundarySize | Returns size of the section boundary. |
![]() | GetEnumerator | |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |