UnloadServices Method


Fabrication Configuration Unload Services Method

Unload the specified fabrication services from the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void UnloadServices(
	IList<int> serviceIds
)

Parameters

serviceIds IList Int32
The identifiers of the fabrication services to unload.
Exceptions
Exception Condition
ArgumentException Fabrication services can not be unloaded if they are in use currently. -or- Some services are not loaded yet.
ArgumentNullException A non-optional argument was null
InvalidOperationException The current fabrication configuration is not connected and updated to source configuration. Reload and try again.
See Also