Shape |
The base class for geometry builder classes.

System Object
Autodesk.Revit.DB ShapeBuilder
Autodesk.Revit.DB BRepBuilder
Autodesk.Revit.DB TessellatedShapeBuilder
Autodesk.Revit.DB ViewShapeBuilder
Autodesk.Revit.DB WireframeBuilder
Autodesk.Revit.DB ShapeBuilder
Autodesk.Revit.DB BRepBuilder
Autodesk.Revit.DB TessellatedShapeBuilder
Autodesk.Revit.DB ViewShapeBuilder
Autodesk.Revit.DB WireframeBuilder
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The ShapeBuilder type exposes the following members.

Name | Description | |
---|---|---|
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the ShapeBuilder |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |