Shape |
The base class for geometry builder classes.

System Object
Autodesk.Revit.DB ShapeBuilder
Autodesk.Revit.DB BRepBuilder
Autodesk.Revit.DB TessellatedShapeBuilder
Autodesk.Revit.DB ViewShapeBuilder
Autodesk.Revit.DB WireframeBuilder
Autodesk.Revit.DB ShapeBuilder
Autodesk.Revit.DB BRepBuilder
Autodesk.Revit.DB TessellatedShapeBuilder
Autodesk.Revit.DB ViewShapeBuilder
Autodesk.Revit.DB WireframeBuilder
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The ShapeBuilder type exposes the following members.

Name | Description | |
---|---|---|
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the ShapeBuilder |